Составьте программу,которая запрашивает значения элементов одномерного числового массива А, состоящего из10 элементов, формирует и выводит на экран в строку данный массив.

Найти сумму элементов, кратных 3;

количество нулевых элементов;

и произведение элементов, стоящих на нечётных местах.

var

 z,i,g,s:longint

a:array[0..100]of longint;

begin

 z:=1;

 for i:=1 to 10 do

begin

 read(a[i]);

 if a[i] mod 3=0 then inc(s,a[i]);

 if a[i]=0 then inc(g);

 if i mod 2>0 then z:=z*a[i];

 write(a[i], );

end;

writeln;

writeln(s);

writeln(g);

writeln(z);

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку