Напишите программу на языке программирования (или составьте алгоритм). Дано натуральное число n. Определите, сколько раз цифра «7» встречается в записи данного числа.
var
a,b,k:integer;
begin
write(Введите число: );
readln(a);
k:=0;
while a<>0 do
begin
b:= a mod 10;
a:= a div 10;
if b=7 then k:=k+1;
end;
writeln(k);
end.
Оцени ответ
