Составить программу Дан массив натуральных чисел , размерность -12
!) Заполнение массива производить с клавиатуры
2) Вывести на печать только элементы кратные 2
3)Найти сумму первых пяти элементов
Составить программу Дан массив целых чисел , размерность -12
1) Заполнение массива производить случайными числами из диапозона [-10;35]
2)Вывести на печать только положительные элементы
3)Найти количество отрицательных элементов
Составить программу
Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .
1 программа
uses crt;
var
a: array [0 .. 12] of integer;
sum, i:integer;
begin
sum:=0;
for i:=1 to 12 do
begin
write(Write a[ ,i, ] = );
readln(a[i]);
end;
for i:=1 to 12 do
begin
if a[i] mod 2=0 then writeln(a[i]);
end;
for i:=1 to 5 do
begin
sum:=a[i]+sum;
end;
write(SUMA = );
writeln(sum);
readln;
end.
2 программа
uses crt;
var
a: array [0 .. 12] of integer;
sum, i:integer;
begin
sum:=0;
for i:=1 to 12 do
begin
a[i]:= random(46)-10; // random(max-min+1)+min;
end;
for i:=1 to 12 do
begin
if (a[i]>0) then writeln(a[i]);
end;
for i:=1 to 12 do
begin
if a[i]<0 then inc(sum);
end;
write(OTRIC ELEMENTOV = );
writeln(sum);
readln;
end.
ткань ...
uses crt;
var
days,m:integer;
begin
days:= 30; //дней в месяце
m:=135; //метров сделали за день
writeln(За месяц = ,days*m, метров );
readln;
end.
