Задача 1

Составить программу

При поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . В массиве A[n] записаны оценки экзаменующихся , полученные на первом экзамене . Подсчитать , сколько человек не допущено ко второму экзамену .

Задача 2

В одномерном массиве , состоящем из n вещественных элементов , вычислить ;

1) минимальный элемент массива;

2)сумму элементов массива , расположенных между первым и последним положительными элементами .

Преобразовать массив таким образом , чтобы сначала располагать все элементы , равные нулю, а потом-все остальные .

Задача1

массив определи как array[];

чтобы посчитать, просто используй счетчик, но сначала инициализируй переменную, которая содержит ответ задачи:

int n;

array [n];

int answer;

for (i=0, i < n, i++)

{

     if (array[i] == 2)

         answer++;

} 

std::cout<

Как то так

 

Задача2 

 

array[n];

 

 

for (int i =1, i < n, i++)

{

 if (array[0] >= array[i])

    array[0] = array[i];

}

std::cout << array[0];

//Это было решение первого пункта

int first;

int last

bool positive;

while (positive == false )

{

   for (int i = 0; i < n; i++)

     {

        if (array[i] > 0)

        {

          positive = true;

          first = i;

          array[i] = -1;

      }

}

while (positive == false )

{

   for (int i = 0, i < n, i++)

     {

        if (array[i] > 0)

        {

          positive = true;

          last = i;

      }

}

 

 

int summ

for (int i = first, i < last, i++)

{

  summ += array[i];

}

 std::cout<

// ПРеобразую

newarray [n];

int a = 0;

for (int i = 0, i < n, i++)

{      

 if (array[i] == 0)  

   {      

newarray[a] = array[i];      

 a++;      

    }  

} 

for (int i = 0, i < n, i++)

{    

     if (array[i] != 0)    

         {        

          newarray[a] = array[i];

         a++;

        }

}

std::cout<< newarray;

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку