Составить алгоритм вычисления площади треугольника со сторонами a, b, c (a, b, c - вещественные положительные числа).

АЛГОРИТМ ВЫЧИСЛЕНИЯ ПЛОЩАДИ ТРЕУГОЛЬНИКА ПО ФОРМУЛЕ ГЕРОНА.

 Площадь вычисляется по следующей формуле

 S=, где P= ;

A, B, C размеры сторон треугольника - аргументы;

S площадь треугольника - результат;

P полупериметр - промежуточная переменная;

 

Program GERON:

  Uses crt;

  Var A,B,C:real;

Begin

  CLRSCR; TEXTCOLOR(1);

  WRITELN(‘ПЛОЩАДЬ ТРЕУГОЛЬНИКА.’);

  WRITELN(‘ПРОГРАММУ СОСТАВИЛА ИВАНОВА СВЕТА.’);

  WRITE(‘ВВЕДИТЕ РАЗМЕРЫ ТРЕХ СТОРОН: ’);

  READLN(A,B,C);

   IF (A<=0) OR (B<=0) OR (C<=0)

       THEN WRITELN (‘ЕСТЬ ОТРИЦАТЕЛЬНЫЕ РАЗМЕРЫ.’)

       ELSE IF (A+B<=C) OR (B+C<=A) OR (A+C<=B)

             THEN WRITELN(‘РАЗМЕРЫ НЕ ТРЕУГОЛЬНИКА.’)

             ELSE BEGIN

                   P:=(A+B+C)/2;

                   S:=SQRT(P*(P-A)*(P-B)*(P-C));

                   WRITELN(‘ПЛОЩАДЬ РАВНА:’, S);

                  END; 

 End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×