Решить на C#, используя циклы.

Составить программу для вычисления и вывода n первых чисел Фибоначчи. Числа Фибоначчи получаются с помощью следующих рекуррентных соотношений f_{1}=f_{2}=1, f_{n}=f_{n-1}+f_{n-2}, ngeq3, где f_{n} - целое. Отследить корретность ввода исходных данных.

using System;

class Program
{
public static int Fibonacci(int n)
{
int a = 0;
int b = 1;
for (int i = 0; i < n; i++)
{
int temp = a;
a = b;
b = temp + b;
}
return a;
}

static void Main()
{
Console.Write("Введите N:");
int n = Int32.Parse(Console.ReadLine());
for (int i = 0; i < n; i++)
{
Console.WriteLine(Fibonacci(i));
}
}
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку