Дан целочисленный массив из 30 элементов, которые могут принимать значения от 0 до 100 – баллы учащихся за итоговый тест по информатике. Напишите программу, которая подсчитывает средний балл класса и выводит на экран номера учеников, набравших баллов больше среднего.

uses crt;
var i,sum:integer; avg:real;
students:array[1..30] of integer;
begin
randomize;
for i:=1 to 30 do students[i]:=random(100)+0;
for i:=1 to 30 do sum:=sum+students[i];
avg:=sum/30;
writeln(sredniy bal = ,avg:0:2);
writeln;
for i:=1 to 30 do begin
if students[i]>avg then
writeln( Student ¹ ,i, nabral = ,students[i], balov);
end;
readln;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку