С клавиатуры вводятся два числа X и Y . Написать программу,определяющую,попала ли точка с координатами (Х,Y) внутрь заштрихованной области (СМ.рисунок)

Program shtrihi;
uses crt;
var
  x,y: real;
begin
  writeln(Введите координаты точки:);
  write(X=); readln(x);
  write(Y=); readln(y);
  writeln(*** alphaues is thinking... ***);
  writeln(***          OK             ***);
  if (y>=0) and (y>=-x+2) and (x*x+y*y<=9) and (y<=exp((1/2)*ln(abs(x)))) then
    begin
      writeln(Точка (,x,,,y,) попадает в заштрихованную область );
    end
  else
    writeln(Точка (,x,,,y,) HE попадает в заштрихованную область );
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку