Составьте программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2;3] и подсчитывает сумму отрицательных чисел. Вывод в столбец с двумя десятичными знаками. Только Паскаль ABC!
Program Program1;
var
i:integer;
sum:real;
a:array [1..16] of real;
begin
randomize;
for i:=1 to 16 do
begin
a[i]:=-2 + Random * 5;
writeln(a[,i,]=,a[i]:0:2);
end;
sum:=0;
for i:=1 to 16 do
if a[i]<0 then sum:=sum+a[i];
writeln(Сумма отрицательных чисел равна,sum:0:2);
end.
Оцени ответ
