Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0;7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3,а к нечётное умножает на 4
Program Program1;
var
i:integer;
a:array [1..10] of integer;
begin
randomize;
writeln;
writeln(Массив до преобразования:);
for i:=1 to 10 do
begin
a[i]:=random(8);
write(a[i],, );
end;
for i:=1 to 10 do
if a[i] mod 2 = 0 then
a[i]:=a[i]+3
else
a[i]:=a[i]*4;
writeln;
writeln(Массив после преобразования:);
for i:=1 to 10 do
write(a[i],, );
end.
Оцени ответ
