Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 3.
(Pascal)
uses crt;
var a:array[1..300] of integer;
i,s,n,k:integer;
begin
clrscr;
s:=0;
write(n=);
read(n);
for i:=1 to n do
begin
read(a[i]);
if (a[i] mod 3=0) then s:=s+a[i];
end;
writeln(s=,s);
end.
Оцени ответ
