Помогите написать программу на Pascal (Задача из ГИА). Заранее огромное спасибо. Напишите программу, которая в последовательности натуральных чисел определяет максимальное число оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число - максимальное число, оканчивающееся на 3.
uses crt;
var a:array[1..1000] of integer;
i,max,n:integer;
begin
clrscr;
write(n<1000, n=);
read(n);
writeln(a[i]<30000, a[i]:);
for i:=1 to n do
begin
readln(a[i]);
if (a[i] mod 10=3) and (a[i]>max) then max:=a[i];
end;
write(max=,max);
end.
Оцени ответ
