Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – количество чисел, оканчивающихся на 3.

uses crt;
var a:array[1..1000] of integer;
i,n,k:integer;
begin
clrscr;
write(n<1000, n=);
read(n);
writeln(a[i]<30000, a[i]:);
for i:=1 to n do
begin
readln(a[i]);
if (a[i] mod 10=3) then k:=k+1;
end;
write(k=,k);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку