Напишите программу, которая в последовательности натуральных
чисел определяет сумму чисел, оканчивающихся на 3. Программа
получает на вход количество чисел в последовательности, а затем сами
числа. В последовательности всегда имеется число, оканчивающееся на 3.
Количество чисел не превышает 100. Введённые числа не превышают 300.
Программа должна вывести одно число – сумму чисел, оканчивающихся на 3.
Program n1;
Uses CRT;
Var s,i: integer;
begin
ClrScr;
Repeat
readln(i);
If (i mod 3=0)or(i mod 100=0) then s:=s+i;
until i=0;
writeln(Сумма =,s);
readln
end.
Оцени ответ
