паскаль прошу очень важно)Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, кратное 4. Пример работы программы:
Сначала вводим n - количество чисел, затем в цикле n раз вводим число, сравниваем с текущим максимальным max, и, если максимальное меньше, вместо максимального записываем текущее число. В качестве начального значения max принимаем 0, т.к. любое натуральное число, делящееся на 4, больше 0.
var
i, t, max, n: integer;
begin
readln(n);
max := 0;
for i := 1 to n do
begin
readln(t);
if (t mod 4 = 0) and (t > max) then
max := t;
end;
writeln(max);
end.
