Тройка положительных числе( а,в,с) называется пифагоровой, если a^2+c^2=c^2.Напишите программу, которая выводит количество различных троек a<=100,b<=100,c<=100.Тройки наз. одинаковыми, если значения a и b меняются местами.Найти мер.,(3,4,5)(4,3,5) одинаковые тройки.
#include
int main()
{
int a, b, c, k=0;
for(a=1;a<101;a++)
for(b=a;b<101;b++)
for(c=a;c<101;c++)
if(a*a+b*b==c*c)
k++;
printf("%i", k);
return 0;
}
Оцени ответ
