Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h. Результат представить в виде таблицы, первый столбец которой — значения аргумента, вто¬рой — соответствующие значения функции: F(x)=xcos(1x)+2 Решить нужно в паскаль.
uses crt;
var a,b,h: real;
function f(x: real): real;
begin
f:=x*cos(1/x)+2;
end;
begin
write(a: );
read(a);
write(b: );
read(b);
write(h: );
read(h);
writeln(Полученный результат:);
writeln( x | f(x) );
while a begin
writeln(a:5:4,|,f(a):5:4);
a:=a+h;
end;
end.
Оцени ответ
