Написать программу на Pacal ABC и составить блок-схему этой программы.
Задание: проверить истинность высказывания: "Все цифры данного трехзначного числа различны"
Программа должна выводить либо True либо False. (с помощью типа: boolean)
Зараннее спасибо!


uses crt;
var
  x:integer;
  y:boolean;
begin
  clrscr;
  write(Введите трехзначное число); read(x);
  y:=((x mod 10)<>(x div 100))and
   ((x div 100)<>(x mod 100 div 10))and
   ((x mod 10)<>(x mod 100 div 10));
  write(y);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку