написать программу на паскале:определить количество строк матрицы, в которых хотя бы один элемент равен t
uses crt;
var
a:array [1..100,1..100] of real;
t:real; i,j,k:integer;
begin
randomize;
write(Введите количество строк матрицы: ); read(i);
write(Введите количество столбцов матрицы: ); read(j);
write(Введите число t: ); read(t);
clrscr;
for i:=1 to i do
begin
for j:=1 to j do
begin
a[i,j]:=random(100)-50;
write(a[i,j], );
end;
writeln;
end;
k:=0;
for i:= 1 to i do
begin
for j:= 1 to j do
begin
if a[i,j]=t then
begin
k:=k+1;
j:=1;
i:=i+1;
end;
end;
end;
writeln(Количество строк: ,k);
end.
Оцени ответ
