Паскаль. Составьте программу вычисления в массиве A(N) произведения четных элементов. Массив сформировать с помощью генератора случайных чисел.
const
n=15;
var
a:array [1..n] of integer;
i:integer;
p:longint;
begin
randomize;
p:=1;
for i:=1 to n do begin
a[i]:=random(9)+1;
write (a[i]:2);
if a[i] mod 2 = 0 then p:=p*a[i];
end;
writeln;
writeln (Proizvedenie: ,p);
readln;
end.
Оцени ответ
