Помогите написать программу в паскале. За ранее спасибо. Задача на одномерный массив.
Задание 3. Даны два массива A и B, состоящих из одинакового числа элементов. Найти среднее арифметическое элементов каждогомассива и сравнить эти значения. Заполнение массива выберите по своему усмотрению.
var
a,b:array [1..10] of integer;
i:integer;
s1,s2:real;
begin
randomize;
for i:=1 to 10 do begin
a[i]:=random(12)-1;
s1:=s1+a[i];
b[i]:=random(9)+1;
s2:=s2+b[i];
write (a[i], );
end;
writeln;
for i:=1 to 10 do write (b[i], );
writeln;
s1:=s1/10;
s2:=s2/10;
writeln (S1 = ,s1);
writeln (S2 = ,s2);
if s1>s2 then writeln (S1>S2) else
if s1 readln; end.
Оцени ответ
