Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального элемента массива
Случайным образом вводятся целые числа от 0 до 999.
max - максимальный элемент массива
i - цикловая переменная.
var
a : array [1..100] of integer;
max, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
max := a [ 1 ];
for i := 2 to n do
if a [ i ] > max then
max := a [ i ];
writeln (max + a [ 1 ])
end.
Оцени ответ
