С клавиатуры вводятся N чисел. Составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. Значение N и сами числа вводится с клавиатуры.
var
n,o,p,k,i:integer;
a:real;
begin
repeat
write (N = );readln(n);
until (n>0);
i:=0;
k:=0;
p:=0;
o:=0;
repeat
write (Ввод: );readln(a);
i:=i+1;
if a<0 then o:=o+1 else
if a>0 then p:=p+1 else k:=k+1;
until i=n;
writeln (Кол-во положительных: ,p);
writeln (Кол-во отрицательных: ,o);
writeln (Кол-во нулей: ,k);
readln;
end.
Оцени ответ
