Составьте программу вычисления значение Sin, Cos и Tg углов от 0 до 45 градусов с шагом 1 градус (с использованием оператора цикла FOR). Для вы-вода результата введите ограничение на количество знаков после запятой. Примечание. В Паскале используются стандартные функции: SIN(X) - синус Х (аргумент задается в радианах); COS(X) - косинус Х (аргумент задается в радианах); Для подсчета угла в радианах используйте формулу: угол в радианах = (угол в градусах)*/180. Результат представьте в виде: Программа вычисления значений тригонометрических функций x° Sin(x) Cos(x) Tg(x) 1 2 3 .. 45
uses crt;
var
x,i:integer;
begin
clrscr;
writeln (X Sin(x) Cos(x) Tg(x));
i:=2;
for x:=0 to 45 do begin
write (x:2, ,sin(x*pi/180):0:4, ,cos(x*pi/180):0:4, );
write (sin(x*pi/180)/cos(x*pi/180):0:4);
writeln;
i:=i+1;
if i=24 then
begin
writeln (Press Enter);
readkey;
end;
end;
readln;
end.
