Написать алгоритм вычисления по формуле: y = (1-x2+2.5x3+x4)2 учитывая следующие ограничения: 1) пользоваться можно операциями сложения, вычитания и умножения; 2) каждое выражение может содержать только одну арифметическую операцию

var y,x:real;

begin

readln(x);

y:=2*(1-x*x+2.5*x*x*x+x*x*x*x);

writeln(x);

end.

 

var x,y,z:real;

begin

readln(x);

y:=-x*x;

z:=y*x;

z:=2.5*z;

y:=y+z;

z:=z*x;

y:=y+z;

y:=y+1;

y:=y*2;

writeln(y);

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку