составить программу на паскале
Дано натуральное число,найти сумму цифр этого числа!

Program Program1;
var
i,sum,n,code:integer;
s:string;
begin
write(Введите натуральноее число: );
readln(s);

sum:=0;
for i := 1 to Length(s) do
begin
Val(s[i], n, code);
sum:=sum + n;
end;
writeln(Сумма цифр: , sum)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку