напишите программу, которая выводит на экран значение n! включая следующую функцию function factorial (n:integer):integer; var p,i:integer; begin p:=1; for i:=1 to n do p:=p*i; factorial:=p; end;

Var n:integer;
      ch:char;
function factorial (n:integer):longint;
  var p,i:integer; 
  begin 
    p:=1;
    for i:=1 to n do p:=p*i; 
    factorial:=p;
end;
begin
    write (N = );
    readln (n);
    writeln (Factorial: ,factorial(n));
    readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку