Имя входного файла:E.in имя выходного файла E.out Дается.. ... Имя входного файла:E.in имя выходного файла E.out Дается последовательность из N чисел.найдите максимальное произ.среди всех пар этих чисел.

Program Pr1;
uses crt;
var mas:array[byte] of integer;
fl1,fl2:text;
stroka:string;
b,v,c,max,i:integer;
Begin
clrscr;
assign(fl1,E.in);
assign(fl2,E.out);
reset(fl1);
readln(fl1,stroka);
close(fl1);
for i:=1 to length(stroka) do val(stroka[i],mas[i],b);
b:=length(stroka);
max:=1;
v:=0;
for i:=1 to b do if mas[i]>v then if mas[i]>max then max:=mas[i]
else v:=mas[i];
c:=max*v;
rewrite(fl2);
writeln(fl2,c);
close(fl2);
end.

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку