Дано натуральное четырехзначное число,верно ли, что все его цифры различны? Написать программу.

var a,b,c,d,e:integer;
begin
read(a);
b:=a mod 10;
a:=a div 10;
c:=a mod 10;
a:=a div 10;
d:=a mod 10;
a:=a div 10;
e:=a mod 10;
if (b<>c) and (b<>d) and (b<>e) and (c<>d) and (c<>e) and (d<>e) then write(net povtorov)
else write(est povtori);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку