1.Составте программу для нахождения граммов G в X унциях (1 унция = 28,35 грамма). Исходное количиство граммов задается с клавиатуры.
2.Напишите программу нахождения длин медиан m1, m2 и m3 треугольника по указанным формулам. Длины сторон a,b и c задаются с клавиатуры.
m1=...
m2=...
m3=...
Const
x = 28.35;
var
g : Real;
begin
Write(Введите кол-во граммов: );
ReadLn(g);
Writeln(g:0:3, грамм = , g/x:0:3, унций.);
Readln;
end.
2:
var
a, b, c : Integer;
m : Real;
begin
Write(Введите сторону a: );
ReadLn(a);
Write(Введите сторону b: );
ReadLn(b);
Write(Введите сторону c: );
ReadLn(c);
m := sqrt(2*sqr(b) + 2*sqr(c) - sqr(a))/2;
Writeln(Медиана к стороне a = , m:0:3);
m := sqrt(2*sqr(a) + 2*sqr(c) - sqr(b))/2;
Writeln(Медиана к стороне b = , m:0:3);
m := sqrt(2*sqr(a) + 2*sqr(b) - sqr(c))/2;
Writeln(Медиана к стороне с = , m:0:3);
Readln;
end.
