Каждая бактерия делится на 2 через каждые 2 минуты. В начальный момент имеется 1 бактерия. Написать программу, определяющую сколько их будет через n минут.

var n,i : integer;
b : real;
begin
readln (n);
b:=1;
for i:=1 to n div 2 do
begin
B:=B*2 ;
end;
writeln(b);
end.

 

вот так)

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку