ОЧЕНЬ СРОЧНО!!!! ПОЖАЛУЙСТА РЕШИТЕ ЗАДАЧУ!!! ЗАРАНЕЕ СПАСИБО!!!!
используя строковый и символьный типы данных, составьте программу для решения задачи:
Дано предложение. Найдите кол-во слов в предложении (слова разделены пробелом)

PascalABC.NET
Программа сработает некорректно если слова будут разделены                       несколькими      пробелами или строка будет заканчиваться пробелом
const      c = ; 
var   
s : string;   
k,p : integer;    
begin 
writeln (Введите строку); 
readln (s); 
k := -1; 
p := 1; 
if (s <> ) and (s <> ) then   
begin   
while p <> 0 do     
begin       
k := k +1;       
p := PosEx (c,s,p+1);      
end;   
writeln (k+1, word)    
end   
else   
writeln (error string); 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку