Ваш друг предлагает вам переписать отснятый им видеофильм. Из носителей информации у вас есть: компакт-диск объемом 650 МБ, дискета объемом 1МБ и флеш-накопитель объемом 1000Мб. Напишите программу, перечисляющую все носители, на которые полностью поместится фильм. Объем видеофайла задается в мегабайтах.

Var
d:integer;
const
a=650;
b=1;
c=1000;
begin
write(Введите объём видеофайла в мегабайтах: );
readln(d);
if d>a then write(Видеофайл не помещается на  носитель информации"А"!,#10) else
writeln(Памяти хватает для записи на носитель "А"! ,#10);
if d>b then write(Видеофайл не помещается на  носитель информации"B"!,#10) else
writeln(Памяти хватает для записи на носитель "B"! ,#10);
if d>c then write(Видеофайл не помещается на данный носитель информации"С"!,#10) else
writeln(Памяти хватает для записи на носитель "C"! ,#10);
readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку