Составить программу вычисления суммы n первых членов арифметической прогрессии по первому ее члену и разности
var n:integer;
s,a1,d:real;
begin
readln(a1,d,n);
s:=(2*a1*n+d*n*(n-1))/2;
writeln(s);
end.
Оцени ответ
Вход
Регистрация
Задать вопрос
var n:integer;
s,a1,d:real;
begin
readln(a1,d,n);
s:=(2*a1*n+d*n*(n-1))/2;
writeln(s);
end.