Пожалуйста решит оч надо
Условная инструкция
Задача «Шахматная доска»
Заданы две клетки шахматной доски. Если они покрашены в один цвет, то выведите слово YES, а если в разные цвета — то NO. Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки.

Var
a1,a2,b1,b2,c1,c2:integer;
begin
writeln(Координаты превой клетки);
writeln(введите номер столбца);
readln(a1);
writeln(введите номер строки);
readln(a2);
writeln(Координаты второй клетки);
writeln(введите номер столбца);
readln(b1);
writeln(введите номер строки);
readln(b2);
if ((a1 mod 2) <> 0) then
if ((a2 mod 2) <> 0) then c1:=0 else c1:=1;
if ((a1 mod 2) = 0) then
if ((a2 mod 2) <> 0) then c1:=1 else c1:=0;
if ((b1 mod 2) <> 0) then
if ((b2 mod 2) <> 0) then c2:=0 else c2:=1;
if ((b1 mod 2) = 0) then
if ((b2 mod 2) <> 0) then c2:=1 else c2:=0;
if c1=c2 then writeln(YES) else writeln(NO)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку