Помогите! Пропустил тему по программированию на PaskalABC. Информатика 10 кл.
Дали самостоятельную...Очень нужно решить 6 заданий.
1) Наименьшее из двух чисел. Даны 2 числа х и у. найти меньшее из них. Если числа равны, то вывести сообщение об этом.
2) Частное любых чисел. Напишите программу, которая запрашивет два целых числа и выводит запись операции их деления. Предусмотрите в программе защиту от аварийной ситуации деления на нуль.
3) Фамильярность. Напишите программу, которая читает строку, и если это ваше имя то печатает на экране привет! а если нет, то здравствуйте! (учтите что у каждого автора программы скоё имя)
4) Чётность числа. Напишите программу которая определяет является ли число чётным.
5) Символ строки с проверкой. Напишите программу выводящую символ с заданным номером из введенной строки. Если символа с таким номером нет, то программа должна напечатать слова: нет символа!
6) Больше фруктов. Одно яблоко весит 100 гр., а один апельсин 150 гр.Вам дают заданное кол-во яблок или заданное кол-во апельсинов. Хочется взять то что весит больше. Напишите программу , подсказывающую, что лучше взять, яблоки или апельсины?
Пример 7 ябл. 5 апельс. вывод: берите апельсины!
Заранее благодарю за помощь!!!
Задача 1
var
x,y:integer;
begin
writeln(Введите х);
readln(x);
writeln(Введите y);
readln(y);
if x
if x=y then writeln(Числа равны)
end.
задача 2
var
x,y:integer;
begin
writeln(Введите первое число);
readln(x);
writeln(Введите второе число);
readln(y);
if y=0 then writeln(Второе число равно 0. Деление невозможно!) else
writeln(x,/,y,=,x/y);
end.
задача 3
var
s,name:string;
begin
writeln(Введите ваше имя);
readln(name);
writeln(Введите строку);
readln(s);
if s=name then writeln(Привет!) else
writeln(Здравствуйте!);
end.
задача 4
var
x:integer;
begin
writeln(Введите число);
readln(x);
if (x mod 2)=0 then writeln(Четное) else writeln(Нечетное)
end.
задача 5
var
x:string;
i:integer;
begin
writeln(Введите строку);
readln(x);
writeln(Введите номер символа);
readln(i);
if i > length(x) then writeln(Нет символа!) else writeln(x[i])
end.
задача 6
var
x,y:integer;
begin
writeln(Количество яблок:);
readln(x);
writeln(Количество апельсинов:);
readln(y);
if (x*100)>(y*150) then writeln(Берите яблоки)
else
if (x*100)<(y*150) then writeln(Берите апельсины)
else
if (x*100)=(y*150) then writeln(Вес яблок и апельсинов одинаковый)
end.
