Дано целое трехзначное положительное число n. составьте программу которая определяет входит ли в него цифра восемь. помогите пожалуйста!!!!!!!!
Const ch=8;
var n:integer;
begin
read(n);
while n>0 do begin
if(n mod 10=ch)then begin
writeln(yes); break;
end;
n:=n div 10;
end;end.
еще можно в строку преобразовать и посимвольно проверить, но мне кажется так нагляднее и алгоритм проще
Оцени ответ
