1. Составить программу вычесления значения функций у по формуле у = 3cos(5x) , для которой значение аргумента х введите с клавиатуры.
2.Составьте программу для решения слкдующей задачи. Ежедневно молочная ферма надаивает Х л молока.Найдите количество молока, полученный за B дней.
3 Дано двузначное число. Вывести вначале его левую цифру(десятки, а затем - его правую цифру(еденицы). Для нахождения десятков использовать операциюделения нацело, для нахождения едениц - операцию взятия остатка от деления.
4. Дано целое число, большее 999. Используя одну операцию деления нацело и одну операцию взятия остатка от деления, найти цифру, соответсвующую разряду сотен в записи этого числа.
5. Выведите с клавиатуры два числа: А и В. Если лба числа четные, то вычеслите их сумму и выведите результат на экран. Если оба - нечетные,то найдите произведение этих чисел и выведите результат. Иначе, увеличьте все числа в пять раз и выведите результаты.
Ребята помогите пожалуйста

1.
var
x:integer;
y:real;
begin
write(Введите значение аргумента "X" : );
readln(x);
y:=3*cos((5*x));
writeln(Значение функции "Y" = ,y);
readln;
end.

2.
var
x,b:integer;
begin
write(Введите количество молока, полученного за день, л : );
readln(x);
write(Введите количество дней : );
readln(b);
writeln(Количество молока, полученного за заданный промежуток времени = ,x*b);
readln;
end.  

3.
var
a,b,c:integer;
begin
write(Введите двузначное число: );
readln(a);
b:=a div 10;
c:=a mod 10;
writeln(b,#10,c);
end.

4.
var
b:integer;
a:longint;
begin
write(Введите целое число: );
readln(a);
  b:=a div 100 mod 100;
writeln(b);
readln;
end.

5. 
var
a,b:integer;
begin
write(Введите числа : );
readln(a,b);
if a and b mod 2=0 then
 writeln(a+b);
if a and b mod 2<>0 then
 writeln(a*b);
readln;
end.
{Про последнее "Иначе", увеличьте все числа в пять раз и выведите результаты" не очень понял....Если оба чётные - сумма, если оба - нечётные - то произведение. А если иначе, то число должно быть равно нулю. Смысл увеличивать его в пять раз?)}


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку