Даны две точки в плоской прямоугольной системе координат. Напишите программу,определяющую, которая из точек находится ближе к началу координат.

может быть так:
var x1,x2,y1,y2:integer;
                      a,b:real;
 begin
  write (Введите x1 и x2: );
  readln (x1,x2);
  write (Введите y1 и y2: );
  readln (y1,y2);
  a:=sqrt (sqr (x1) + sqr (y1));
  b:=sqrt (sqr (x2) + sqr (y2));
  if a>b then writeln (1-я точка ближе)
  else writeln (2-я точка ближе);
 end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку