Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, меньших 500 и кратных 3. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают 30 000.
Программа должна вывести одно число: количество натуральных чисел, меньших 500 и кратных 3.

Program gt;
var a,h:longint;
begin
read(a);
h:=0;
while (a<>0) do
begin
if(a<500)and(a mod 3=0)then h:=h+1;      //или Inc(h) вместо h:=h+1;
read(a);
end;
writeln(h);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку