Написать программу на алгоритмическом языке Паскаль. Вывести наименование и стоимость продукта, которого на складе меньше всего.

Const
  nm = 50;{ предельное число товаров }

var
  mn: array[1..nm] of string;
  mk, ms: array[1..nm] of real;
  i, k, n: integer;
  min: real;

begin
  Write(Введите число продуктов на складе (не более , nm, ): );
  Readln(n);
  min := 1e10;
  for i := 1 to n do
  begin
    Write(Наименование продукта , i, : ); Readln(mn[i]);
    Write(Количество и стоимость: ); Readln(mk[i], ms[i]);
    if min > mk[i] then begin min := mk[i]; k := i end
  end; 
  Writeln(На складе меньше всего продукта , mn[k], : , mk[k],
    кг. стоимостью , ms[k], руб. за 1 кг.)
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку