Помогите пожалуйста
Что будет выведено на экран в результате выполнения программы, если в ответ на приглашение введено слово cat?
Var x,y: char;
Begin
Writeln (‘введите несколько символов’);
Readln (x,y);
Writeln (x,y,y);
End.
А) cat б) ccc в) caa г) ca
2.Как будут выведены значения переменных А и В операторами writeln (A); writeln (B);
а) через строку; б) через пробел в) в столбик г) слитно
3.Какой тип данных в языке Pascal предназначен для хранения символьной информации?
а) real б) integer в) char г) byte
4. Есть ли ошибки в записи команды: Readln (введи радиус, R)
а) нет ошибок б) пояснительный текст не заключен в апострофы
в) пояснительный текст не нужен г) лишнее слово “введи”
5. При выполнении операции присваивания символа переменной
а) символ заключается в кавычки б) символ записывается через пробел от знака присваивания в) символ заключается в апострофы
г) символ записывается в скобках Задачи по теме «Обработка текстовых данных»
1. Составить программу подсчета количества вхождений буквы “а” в заданном тексте.
2. Даны две строки, выяснить совпадают ли их длины.
1 - в) caa
2 - в) в столбик
3 - в) char
4 - в) пояснительный текст не нужен
5 - в) символ заключается в апострофы
1)
Var s1: string;
i,a:integer;
Begin
Writeln (введите текст);
Readln (s1);
for i:=1 to length(s1) do
if (s1[i]=а)or(s1[i]=a) then a:=a+1;
writeln(количество букв а в тексте: ,a);
End.
2)
Var s1,s2: string;
Begin
Writeln (введите первую строку);
Readln (s1);
Writeln (введите вторую строку);
Readln (s2);
if length(s1)=length(s2) then writeln(длины строк совпадают)
else writeln(длины строк не совпадают)
End.
Оцени ответ