Напишите программу которая определяет верно ли что введенное число содержит по крайней мере две одинаковые цифры возможно не стоящие рядом как например 212

var
  s: string;
  i, j, n: integer;
  c: char;
  flag: boolean;

begin
  Write(Введите произвольное число: ); Readln(s);
  flag := false;
  n := length(s);
  i := 1;
  while (i <= n) and (not flag) do
  begin
    c := s[i];
    j := i + 1;
    while (j <= n) and (not flag) do
      if s[j] = c then flag := true else j := j + 1;
    if (not flag) then i := i + 1
  end;
  if flag then Writeln(Символ ", c, " встречается больше одного раза)
  else Writeln(Все символы уникальны)
end.

Тестовое решение:
Введите произвольное число: -1453.5462
Символ "4" встречается больше одного раза

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку