Напишите программу которая вводит последовательность целых чисел заканчивающихся нулём и определяет сколько из этих чисел удовлетворяет условию:сумма значений цифр десятичной записи числа равно 10
Pascal
const
n = 100; // Максимальное число элементов
var a : array [1..n] of integer;
L,i,c,s,k : integer;
begin
L := 1;
c := 10;
while c <> 0 do
begin
readln (c);
a[L] := c;
L := L + 1;
end;
l := l -1;
k := 0;
for i := 1 to L do
begin
c := a[i];
s := 0;
while c <> 0 do
begin
s := s + c mod 10;
c := c div 10;
end;
if s = 10 then
k := k + 1;
end;
writeln ();
writeln (k);
end.
Оцени ответ
