Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case.

Эта программа действительна при условии, что утро начинается в 6, день в 12, вечер в 18, а ночь в 24 и продолжается до 6. Написала через if, так как не знакома с case, буду рада, если кто-нибудь мне расскажет)

var  a: integer;
begin
  read(a); 
 if (a > 5) and (a <= 11) then
    write(Утро );
 if (a > 11) and (a <= 17) then
    write(День );
 if (a > 17) and (a <= 23) then
    write(Вечер); 
 if (a = 24) or (a < 6) then 
    write(Ночь);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку