Написать программу для нахождения суммы 1/1+1/2+1/3+....1/n

Var c,c1:real;
i,b,a,b1,n:integer;
begin
readln(n);
b:=1; a:=1; c:=0;
for i:=1 to n do
begin
b1:=b+1;
c:=a/b1;
end;
c1:=c+(1/1);
write(c1:0:3);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку