Дано трехзначное число. напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые

Ну как то так :)

program mm;
var
i:integer;
b,a,c:char;
begin
readln(a,b,c);
if (a=c) and (a=b) then writeln(есть три одинаковые цифры ,a)
else
if a=b then writeln(есть две одинаковые цифры ,a)
else
if a=c then writeln(есть две одинаковые цифры ,a)
else
if b=c then writeln(есть две одинаковые цифры ,b);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку