Составьте программу вычисления корней квадратного уравнения по данным значениям его корней пожалуйста
Код на Java прикреплен
паскаль
var a,b,c:integer;
d1,d2,d:real;
beginreadln(a,b,c);
d:=(b*b)-(4*a*c);
writeln(d:0:0);
if d<0 then write(Корней нет);
if d=0 then begin d1:=-b/(2*a); write(d1:0:0); end;
if d>0 then begin d1:=(-b - sqrt(d))/(2*a); d2:=(-b+sqrt(d))/(2*a); writeln(d1:0:0,d2:0:0); end
end.
Оцени ответ
