Напишите программу, которая вводит натуральное число N и выводит на экран все натуральные числа, не превосходящие N и делящиеся на каждую из своих цифр.

Function del(a:integer):boolean;
var k:integer;
begin
del:=true;
k:=a;
while(k<>0) do begin
  if(k mod 10 = 0) then begin del:=false; break; end
  else if(a mod (k mod 10) <> 0) then del:=false;
  k:=k div 10;
  end;
end;

var i,n:integer;
begin
read(n);
for i:=1 to n do
  if(del(i)) then write(i, );
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку