Написать программу , осуществляющую заполнение массива случайными числами из интервала от -10 до 10, вывести его на экран, а затем все элементы из интервала от -5 до 5 увеличить на 1, массив повторно вы¬вести на экран.
Вот на Java, в паскаль лень переводить. Если все же нужно, то отпишите в скайп - vasilevich24.
public class zadanie4 {
public static void main(String[] args) { .
int a[];
a=new int [150];
System.out.println("Исходныймассив:");
for (int i=0;i<15;i++) {
a[i]=(int) Math.floor(Math.random()*20)-10; System.out.println("a["+i+"]="+a[i]);}
for (int i=0;i<15;i++){
if (a[i]>=-5 && a[i]<=5){ a[i]=a[i]+1;}}
System.out.println("Полученный массив:");
for (int i=0;i<15;i++) { System.out.println("a["+i+"]="+a[i]);}}}
Оцени ответ
